What’s Vulnerable › Vulnerabilities

CVE-2024-1963: Uncontrolled Resource Consumption in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 8.4 prior to 16.10.7, starting from 16.11 prior to 16.11.4, and starting from 17.0 prior to 17.0.2. A vulnerability in GitLab's Asana integration allowed an attacker to potentially cause a regular expression denial of service by sending specially crafted requests.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.10.7, 16.11.4, 17.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-1963 or the next vulnerability affects your stack