What’s Vulnerable › Vulnerabilities
CVE-2024-1978: Friends <= 2.8.5 - Authenticated (Admin+) Blind Server-Side Request Forgery
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-29 · updated 2026-06-17
- Weakness: CWE-918
Description
The Friends plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.8.5 via the discover_available_feeds function. This makes it possible for authenticated attackers, with administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
Affected products
- akirk Friends: before 2.8.6 — fixed in 2.8.6
How to fix
Upgrade to a fixed version: akirk Friends 2.8.6. Check the vendor advisory for mitigations.
References
- https://github.com/akirk/friends/pull/290
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3036987%40friends&new=3036987%40friends&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/72e1fbce-86ae-4518-a613-7c322193acf4?source=cve
- https://github.com/akirk/friends/pull/290
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3036987%40friends&new=3036987%40friends&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/72e1fbce-86ae-4518-a613-7c322193acf4?source=cve
Get alerted when CVE-2024-1978 or the next vulnerability affects your stack