What’s Vulnerable › Vulnerabilities
CVE-2024-2020: Calculated Fields Form Professional <= 5.1.56 - Unauthenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Calculated Fields Form plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the form page href parameter in all versions up to, and including, 5.1.56 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires the professional version or higher.
Affected products
- codepeople Calculated Fields Form: before 5.1.57 — fixed in 5.1.57
How to fix
Upgrade to a fixed version: codepeople Calculated Fields Form 5.1.57. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/calculated-fields-form/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/45bfa9fb-f35b-4fd4-8553-cf87bf69df6b?source=cve
- https://wordpress.org/plugins/calculated-fields-form/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/45bfa9fb-f35b-4fd4-8553-cf87bf69df6b?source=cve
Get alerted when CVE-2024-2020 or the next vulnerability affects your stack