What’s Vulnerable › Vulnerabilities
CVE-2024-2026: Passster <= 4.2.6.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via content_protector Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The Passster plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's content_protector shortcode in all versions up to, and including, 4.2.6.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- wpchill Passster – Password Protect Pages and Content: before 4.2.6.5 — fixed in 4.2.6.5
How to fix
Upgrade to a fixed version: wpchill Passster – Password Protect Pages and Content 4.2.6.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/content-protector/trunk/inc/class-ps-public.php#L48
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3064573%40content-protector&new=3064573%40content-protector&sfp_email=&sfph_mail=#file7
- https://www.wordfence.com/threat-intel/vulnerabilities/id/880f1f3f-857c-46da-a65c-082348260f89?source=cve
- https://plugins.trac.wordpress.org/browser/content-protector/trunk/inc/class-ps-public.php#L48
- https://www.wordfence.com/threat-intel/vulnerabilities/id/880f1f3f-857c-46da-a65c-082348260f89?source=cve
Get alerted when CVE-2024-2026 or the next vulnerability affects your stack