What’s Vulnerable › Vulnerabilities
CVE-2024-20271
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-27 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in the IP packet processing of Cisco Access Point (AP) Software could allow an unauthenticated, remote attacker to cause a denial of service (DoS) condition on an affected device. This vulnerability is due to insufficient input validation of certain IPv4 packets. An attacker could exploit this vulnerability by sending a crafted IPv4 packet either to or through an affected device. A successful exploit could allow the attacker to cause an affected device to reload unexpectedly, resulting in a DoS condition. To successfully exploit this vulnerability, the attacker does not need to be associated with the affected AP. This vulnerability cannot be exploited by sending IPv6 packets.
Affected products
- Cisco Business Access Points: before 10.9.1.0; before 10.6.2.0 — fixed in 10.6.2.0, 10.9.1.0
- Cisco IOS XE: before 17.3.8; from 17.4 before 17.6.6; from 17.7 before 17.9.5; from 17.10 before 17.12.2 — fixed in 17.12.2, 17.3.8, 17.6.6, 17.9.5
- Cisco Wireless LAN Controller (WLC): before 8.10.190.0 — fixed in 8.10.190.0
How to fix
Upgrade to a fixed version: Cisco Business Access Points 10.6.2.0, 10.9.1.0; Cisco IOS XE 17.12.2, 17.3.8, 17.6.6, 17.9.5; Cisco Wireless LAN Controller (WLC) 8.10.190.0. Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ap-dos-h9TGGX6W
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ap-dos-h9TGGX6W
Get alerted when CVE-2024-20271 or the next vulnerability affects your stack