What’s Vulnerable › Vulnerabilities
CVE-2024-2028: Exclusive Addons for Elementor <= 2.6.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via Covid-19 Stats Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Exclusive Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Covid-19 Stats Widget in all versions up to, and including, 2.6.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- timstrifler Exclusive Addons for Elementor: before 2.6.9.1 — fixed in 2.6.9.1
How to fix
Upgrade to a fixed version: timstrifler Exclusive Addons for Elementor 2.6.9.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3042217/exclusive-addons-for-elementor
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d44ecf8a-d19a-403a-96c7-89e223a5cc22?source=cve
- https://plugins.trac.wordpress.org/changeset/3042217/exclusive-addons-for-elementor
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d44ecf8a-d19a-403a-96c7-89e223a5cc22?source=cve
Get alerted when CVE-2024-2028 or the next vulnerability affects your stack