What’s Vulnerable › Vulnerabilities
CVE-2024-2029: Command Injection in mudler/localai
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-10 · updated 2026-06-17
- Weakness: CWE-78
Description
A command injection vulnerability exists in the `TranscriptEndpoint` of mudler/localai, specifically within the `audioToWav` function used for converting audio files to WAV format for transcription. The vulnerability arises due to the lack of sanitization of user-supplied filenames before passing them to ffmpeg via a shell command, allowing an attacker to execute arbitrary commands on the host system. Successful exploitation could lead to unauthorized access, data breaches, or other detrimental impacts, depending on the privileges of the process executing the code.
Affected products
- mudler/localai: before 2.10.0 — fixed in 2.10.0
How to fix
Upgrade to a fixed version: mudler/localai 2.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/mudler/localai/commit/31a4c9c9d3abc58de2bdc5305419181c8b33eb1c
- https://huntr.com/bounties/e092528a-ce3b-4e66-9b98-3f56d6b276b0
- https://github.com/mudler/localai/commit/31a4c9c9d3abc58de2bdc5305419181c8b33eb1c
- https://huntr.com/bounties/e092528a-ce3b-4e66-9b98-3f56d6b276b0
Get alerted when CVE-2024-2029 or the next vulnerability affects your stack