What’s Vulnerable › Vulnerabilities
CVE-2024-2035: Improper Authorization in zenml-io/zenml
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-06 · updated 2026-06-17
- Weakness: CWE-862
Description
An improper authorization vulnerability exists in the zenml-io/zenml repository, specifically within the API PUT /api/v1/users/id endpoint. This vulnerability allows any authenticated user to modify the information of other users, including changing the `active` status of user accounts to false, effectively deactivating them. This issue affects version 0.55.3 and was fixed in version 0.56.2. The impact of this vulnerability is significant as it allows for the deactivation of admin accounts, potentially disrupting the functionality and security of the application.
Affected products
- zenml-io/zenml: before 0.56.2 — fixed in 0.56.2
How to fix
Upgrade to a fixed version: zenml-io/zenml 0.56.2. Check the vendor advisory for mitigations.
References
- https://github.com/zenml-io/zenml/commit/b95f083efffa56831cd41d8ed536aeb0b6038fa3
- https://huntr.com/bounties/1cfc6493-082e-4229-9f2f-496801a6557c
- https://github.com/zenml-io/zenml/commit/b95f083efffa56831cd41d8ed536aeb0b6038fa3
- https://huntr.com/bounties/1cfc6493-082e-4229-9f2f-496801a6557c
Get alerted when CVE-2024-2035 or the next vulnerability affects your stack