What’s Vulnerable › Vulnerabilities
CVE-2024-20366
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-15 · updated 2026-06-17
- Weakness: CWE-73
Description
A vulnerability in the Tail-f High Availability Cluster Communications (HCC) function pack of Cisco Crosswork Network Services Orchestrator (NSO) could allow an authenticated, local attacker to elevate privileges to root on an affected device. This vulnerability exists because a user-controlled search path is used to locate executable files. An attacker could exploit this vulnerability by configuring the application in a way that causes a malicious file to be executed. A successful exploit could allow the attacker to execute arbitrary code on an affected device as the root user. To exploit this vulnerability, the attacker would need valid credentials on an affected device.
Affected products
- Cisco Network Services Orchestrator: from 5.0 before 5.0.5; from 6.0 before 6.0.2 — fixed in 5.0.5, 6.0.2
How to fix
Upgrade to a fixed version: Cisco Network Services Orchestrator 5.0.5, 6.0.2. Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-nso-hcc-priv-esc-OWBWCs5D
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-nso-hcc-priv-esc-OWBWCs5D
Get alerted when CVE-2024-20366 or the next vulnerability affects your stack