What’s Vulnerable › Vulnerabilities
CVE-2024-20367
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-03 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in the web UI of Cisco Enterprise Chat and Email (ECE) could allow an authenticated, remote attacker to conduct a cross-site scripting (XSS) attack against a user of the interface. This vulnerability exists because the web UI does not properly validate user-supplied input. An attacker could exploit this vulnerability by persuading a user of the interface to click a crafted link. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive, browser-based information. To successfully exploit this vulnerability, an attacker would need valid agent credentials.
Affected products
- Cisco Enterprise Chat and Email: from 12.5(1) before 12.5(1)es9; from 12.6(1) before 12.6(1)es7 — fixed in 12.5(1)es9, 12.6(1)es7
How to fix
Upgrade to a fixed version: Cisco Enterprise Chat and Email 12.5(1)es9, 12.6(1)es7. Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ece-xss-CSQxgxfM
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ece-xss-CSQxgxfM
Get alerted when CVE-2024-20367 or the next vulnerability affects your stack