What’s Vulnerable › Vulnerabilities
CVE-2024-20385: Cisco Nexus Dashboard Orchestrator SSL Certificate Validation Vulnerability
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-02 · updated 2026-06-17
- Weakness: CWE-295
Description
A vulnerability in the SSL/TLS implementation of Cisco Nexus Dashboard Orchestrator (NDO) could allow an unauthenticated, remote attacker to intercept sensitive information from an affected device. This vulnerability exists because the Cisco NDO Validate Peer Certificate site management feature validates the certificates for Cisco Application Policy Infrastructure Controller (APIC), Cisco Cloud Network Controller (CNC), and Cisco Nexus Dashboard only when a new site is added or an existing one is reregistered. An attacker could exploit this vulnerability by using machine-in-the-middle techniques to intercept the traffic between the affected device and Cisco NDO and then using a crafted certificate to impersonate the affected device. A successful exploit could allow the attacker to learn sensitive information during communications between these devices.
Affected products
- Cisco Nexus Dashboard Orchestrator: before 4.2\(3o\); from 4.3.0 before 4.4\(1.1009\) — fixed in 4.2\(3o\), 4.4\(1.1009\)
How to fix
Upgrade to a fixed version: Cisco Nexus Dashboard Orchestrator 4.2\(3o\), 4.4\(1.1009\). Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-20385 or the next vulnerability affects your stack