What’s Vulnerable › Vulnerabilities
CVE-2024-20404
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 22.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-05 · updated 2026-06-17
- Weakness: CWE-918
Description
A vulnerability in the web-based management interface of Cisco Finesse could allow an unauthenticated, remote attacker to conduct an SSRF attack on an affected system. This vulnerability is due to insufficient validation of user-supplied input for specific HTTP requests that are sent to an affected system. An attacker could exploit this vulnerability by sending a crafted HTTP request to the affected device. A successful exploit could allow the attacker to obtain limited sensitive information for services that are associated to the affected device.
Affected products
- Cisco Finesse: before 11.6\(1\); 11.6(1), 11.6(1)-es4, 11.6(1)-es5, 11.6(1)-es6, 11.6(1)-es7, 11.6(1)-es8 (+3) — fixed in 11.6\(1\)
How to fix
Upgrade to a fixed version: Cisco Finesse 11.6\(1\). Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-finesse-ssrf-rfi-Um7wT8Ew
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-finesse-ssrf-rfi-Um7wT8Ew
Get alerted when CVE-2024-20404 or the next vulnerability affects your stack