What’s Vulnerable › Vulnerabilities
CVE-2024-20405
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-05 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in the web-based management interface of Cisco Finesse could allow an unauthenticated, remote attacker to conduct a stored XSS attack by exploiting an RFI vulnerability. This vulnerability is due to insufficient validation of user-supplied input for specific HTTP requests that are sent to an affected device. An attacker could exploit this vulnerability by persuading a user to click a crafted link. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive information on the affected device.
Affected products
- Cisco Finesse: before 11.6\(1\); 11.6(1), 11.6(1)-es4, 11.6(1)-es5, 11.6(1)-es6, 11.6(1)-es7, 11.6(1)-es8 (+3) — fixed in 11.6\(1\)
How to fix
Upgrade to a fixed version: Cisco Finesse 11.6\(1\). Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-finesse-ssrf-rfi-Um7wT8Ew
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-finesse-ssrf-rfi-Um7wT8Ew
Get alerted when CVE-2024-20405 or the next vulnerability affects your stack