What’s Vulnerable › Vulnerabilities
CVE-2024-2044: Unsafe Deserialisation and Remote Code Execution by an Authenticated user in pgAdmin 4
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 79.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-07 · updated 2026-06-17
- Weakness: CWE-31
Description
pgAdmin <= 8.3 is affected by a path-traversal vulnerability while deserializing users’ sessions in the session handling code. If the server is running on Windows, an unauthenticated attacker can load and deserialize remote pickle objects and gain code execution. If the server is running on POSIX/Linux, an authenticated attacker can upload pickle objects, deserialize them, and gain code execution.
Affected products
- Fedoraproject Fedora: 40
- pgadmin.org pgAdmin 4: before 8.4 — fixed in 8.4
How to fix
Upgrade to a fixed version: pgadmin.org pgAdmin 4 8.4. Check the vendor advisory for mitigations.
References
- https://github.com/pgadmin-org/pgadmin4/issues/7258
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/LUYN2JXKKHFSVTASH344TBRGWDH64XQV/
- https://www.shielder.com/advisories/pgadmin-path-traversal_leads_to_unsafe_deserialization_and_rce/
- https://github.com/pgadmin-org/pgadmin4/issues/7258
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/LUYN2JXKKHFSVTASH344TBRGWDH64XQV/
- https://www.shielder.com/advisories/pgadmin-path-traversal_leads_to_unsafe_deserialization_and_rce/
Get alerted when CVE-2024-2044 or the next vulnerability affects your stack