What’s Vulnerable › Vulnerabilities
CVE-2024-20442: Cisco Nexus Dashboard Unauthorized API Endpoints Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-02 · updated 2026-06-17
- Weakness: CWE-862
Description
A vulnerability in the REST API endpoints of Cisco Nexus Dashboard could allow an authenticated, low-privileged, remote attacker to perform limited Administrator actions on an affected device. This vulnerability is due to insufficient authorization controls on some REST API endpoints. An attacker could exploit this vulnerability by sending crafted API requests to an affected endpoint. A successful exploit could allow the attacker to perform limited Administrator functions such as viewing portions of the web UI, generating config only or full backup files, and deleting tech support files. This vulnerability only affects a subset of REST API endpoints and does not affect the web-based management interface.
Affected products
- Cisco Nexus Dashboard: before 3.2\(1e\) — fixed in 3.2\(1e\)
- Cisco Nexus Dashboard Fabric Controller: from 12.0.0 through 12.2.2
How to fix
Upgrade to a fixed version: Cisco Nexus Dashboard 3.2\(1e\). Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-20442 or the next vulnerability affects your stack