What’s Vulnerable › Vulnerabilities
CVE-2024-20466: Cisco Identity Services Engine Sensitive Information Disclosure Vulnerability
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-21 · updated 2026-06-17
- Weakness: CWE-266
Description
A vulnerability in the web-based management interface of Cisco Identity Services Engine (ISE) could allow an authenticated, remote attacker to obtain sensitive information from an affected device. This vulnerability is due to improper enforcement of administrative privilege levels for high-value sensitive data. An attacker with read-only Administrator privileges for the web-based management interface on an affected device could exploit this vulnerability by browsing to a page that contains sensitive data. A successful exploit could allow the attacker to collect sensitive information regarding the configuration of the system.
Affected products
- Cisco Identity Services Engine: from 2.7.0 before 3.1; 3.1.0, 3.1.0-patch1, 3.1.0-patch2, 3.1.0-patch3, 3.1.0-patch4, 3.1.0-patch5 (+11) — fixed in 3.1
How to fix
Upgrade to a fixed version: Cisco Identity Services Engine 3.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-20466 or the next vulnerability affects your stack