What’s Vulnerable › Vulnerabilities
CVE-2024-20487: Cisco Identity Services Engine Stored Cross-Site Scripting Vulnerabiliy
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-06 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in the web-based management interface of Cisco ISE could allow an authenticated, remote attacker to conduct a stored XSS attack against a user of the interface. This vulnerability is due to insufficient validation of user-supplied input by the web-based management interface of an affected system. An attacker could exploit this vulnerability by injecting malicious code into specific pages of the interface. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive, browser-based information. To exploit this vulnerability, the attacker must have at least a low-privileged account on an affected device.
Affected products
- Cisco Identity Services Engine: from 3.0.0 before 3.1.0; 3.1.0, 3.1.0-patch1, 3.1.0-patch2, 3.1.0-patch3, 3.1.0-patch4, 3.1.0-patch5 (+15) — fixed in 3.1.0
How to fix
Upgrade to a fixed version: Cisco Identity Services Engine 3.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-20487 or the next vulnerability affects your stack