What’s Vulnerable › Vulnerabilities
CVE-2024-20506: ClamAV Privilege Handling Escalation Vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-04 · updated 2026-06-17
- Weakness: CWE-754
Description
A vulnerability in the ClamD service module of Clam AntiVirus (ClamAV) versions 1.4.0, 1.3.2 and prior versions, all 1.2.x versions, 1.0.6 and prior versions, all 0.105.x versions, all 0.104.x versions, and 0.103.11 and all prior versions could allow an authenticated, local attacker to corrupt critical system files. The vulnerability is due to allowing the ClamD process to write to its log file while privileged without checking if the logfile has been replaced with a symbolic link. An attacker could exploit this vulnerability if they replace the ClamD log file with a symlink to a critical system file and then find a way to restart the ClamD process. An exploit could allow the attacker to corrupt a critical system file by appending ClamD log messages after restart.
Affected products
- Cisco ClamAV: before 0.103.12; from 0.104.0 before 1.0.7; from 1.2.0 before 1.3.2; 1.4.0 — fixed in 0.103.12, 1.0.7, 1.3.2
How to fix
Upgrade to a fixed version: Cisco ClamAV 0.103.12, 1.0.7, 1.3.2. Check the vendor advisory for mitigations.
References
- https://blog.clamav.net/2024/09/clamav-141-132-107-and-010312-security.html
- https://lists.debian.org/debian-lts-announce/2024/12/msg00004.html
Get alerted when CVE-2024-20506 or the next vulnerability affects your stack