What’s Vulnerable › Vulnerabilities
CVE-2024-20514: Cisco Evolved Programmable Network Manager and Cisco Prime Infrastructure Stored Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-06 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in the web-based management interface of Cisco Evolved Programmable Network Manager (EPNM) and Cisco Prime Infrastructure could allow an authenticated, low-privileged, remote attacker to conduct a stored cross-site scripting (XSS) attack against a user of the interface. This vulnerability exists because the web-based management interface does not properly validate user-supplied input. An attacker could exploit this vulnerability by injecting malicious code into a specific page of the interface. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive browser-based information. To exploit this vulnerability, the attacker must have at least a low-privileged account on an affected device.
Affected products
- Cisco Evolved Programmable Network Manager (EPNM): before 8.0.0 — fixed in 8.0.0
- Cisco Prime Infrastructure: before 3.10.6 — fixed in 3.10.6
How to fix
Upgrade to a fixed version: Cisco Evolved Programmable Network Manager (EPNM) 8.0.0; Cisco Prime Infrastructure 3.10.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-20514 or the next vulnerability affects your stack