What’s Vulnerable › Vulnerabilities
CVE-2024-20527: Cisco Identity Services Engine Arbitrary File Read and Delete Vulnerability
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-06 · updated 2026-06-17
- Weakness: CWE-22
Description
A vulnerability in the API of Cisco ISE could allow an authenticated, remote attacker to read and delete arbitrary files on an affected device. To exploit this vulnerability, the attacker would need valid Super Admin credentials. This vulnerability is due to insufficient validation of user-supplied parameters in API requests. An attacker could exploit this vulnerability by sending a crafted API request to an affected device. A successful exploit could allow the attacker to read or delete arbitrary files on the underlying operating system.
Affected products
- Cisco Identity Services Engine: from 3.0.0 before 3.1.0; 3.1.0, 3.1.0-patch1, 3.1.0-patch2, 3.1.0-patch3, 3.1.0-patch4, 3.1.0-patch5 (+15) — fixed in 3.1.0
How to fix
Upgrade to a fixed version: Cisco Identity Services Engine 3.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-20527 or the next vulnerability affects your stack