What’s Vulnerable › Vulnerabilities
CVE-2024-20528: Cisco Identity Services Engine Path Traversal Vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-06 · updated 2026-06-17
- Weakness: CWE-22
Description
A vulnerability in the API of Cisco ISE could allow an authenticated, remote attacker to upload files to arbitrary locations on the underlying operating system of an affected device. To exploit this vulnerability, an attacker would need valid Super Admin credentials. This vulnerability is due to insufficient validation of user-supplied parameters in API requests. An attacker could exploit this vulnerability by sending a crafted API request to an affected device. A successful exploit could allow the attacker to upload custom files to arbitrary locations on the underlying operating system, execute arbitrary code, and elevate privileges to root.
Affected products
- Cisco Identity Services Engine: from 3.0.0 before 3.1.0; 3.1.0, 3.1.0-patch1, 3.1.0-patch2, 3.1.0-patch3, 3.1.0-patch4, 3.1.0-patch5 (+15) — fixed in 3.1.0
How to fix
Upgrade to a fixed version: Cisco Identity Services Engine 3.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-20528 or the next vulnerability affects your stack