What’s Vulnerable › Vulnerabilities

CVE-2024-20737: Adobe After Effect 2024 RGB File parsing Memory Corruption Vulnerability

Description

After Effects versions 24.1, 23.6.2 and earlier are affected by an out-of-bounds read vulnerability that could lead to disclosure of sensitive memory. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Affected products

How to fix

Upgrade to a fixed version: Adobe After Effects 23.6.5, 24.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-20737 or the next vulnerability affects your stack