What’s Vulnerable › Vulnerabilities
CVE-2024-20739: ZDI-CAN-22647: Adobe Audition AVI File Parsing Heap-based Buffer Overflow Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-15 · updated 2026-06-17
- Weakness: CWE-122
Description
Audition versions 24.0.3, 23.6.2 and earlier are affected by a Heap-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Audition: before 23.6.4; from 24.0 before 24.2 — fixed in 23.6.4, 24.2
How to fix
Upgrade to a fixed version: Adobe Audition 23.6.4, 24.2. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/audition/apsb24-11.html
- https://helpx.adobe.com/security/products/audition/apsb24-11.html
Get alerted when CVE-2024-20739 or the next vulnerability affects your stack