What’s Vulnerable › Vulnerabilities

CVE-2024-20745: ZDI-CAN-22671: Adobe Premiere Pro AVI File Parsing Heap-based Buffer Overflow Remote Code Execution Vulnerability

Description

Premiere Pro versions 24.1, 23.6.2 and earlier are affected by a Heap-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Affected products

How to fix

Upgrade to a fixed version: Adobe Premiere 23.6.4, 24.2.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-20745 or the next vulnerability affects your stack