What’s Vulnerable › Vulnerabilities
CVE-2024-20753: Adobe Photoshop PDF File Parsing Memory Corruption Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-13 · updated 2026-06-17
- Weakness: CWE-125
Description
Photoshop Desktop versions 24.7.3, 25.7 and earlier are affected by an out-of-bounds read vulnerability when parsing a crafted file, which could result in a read past the end of an allocated memory structure. An attacker could leverage this vulnerability to execute code in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Photoshop: before 24.7.4; from 25.0 before 25.9 — fixed in 24.7.4, 25.9
How to fix
Upgrade to a fixed version: Adobe Photoshop 24.7.4, 25.9. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/photoshop/apsb24-27.html
- https://helpx.adobe.com/security/products/photoshop/apsb24-27.html
Get alerted when CVE-2024-20753 or the next vulnerability affects your stack