What’s Vulnerable › Vulnerabilities
CVE-2024-20791: Illustrator 2024 BMP File Parsing Memory Corruption
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-16 · updated 2026-06-17
- Weakness: CWE-125
Description
Illustrator versions 28.4, 27.9.3 and earlier are affected by an out-of-bounds read vulnerability when parsing a crafted file, which could result in a read past the end of an allocated memory structure. An attacker could leverage this vulnerability to execute code in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Illustrator: before 27.9.4; from 28.0 before 28.5 — fixed in 27.9.4, 28.5
How to fix
Upgrade to a fixed version: Adobe Illustrator 27.9.4, 28.5. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/illustrator/apsb24-30.html
- https://helpx.adobe.com/security/products/illustrator/apsb24-30.html
Get alerted when CVE-2024-20791 or the next vulnerability affects your stack