What’s Vulnerable › Vulnerabilities
CVE-2024-20792: Adobe Illustrator TIF File Parsing Use-After-Free Remote memory corruption
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-16 · updated 2026-06-17
- Weakness: CWE-416
Description
Illustrator versions 28.4, 27.9.3 and earlier are affected by a Use After Free vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Illustrator: before 27.9.4; from 28.0 before 28.5 — fixed in 27.9.4, 28.5
How to fix
Upgrade to a fixed version: Adobe Illustrator 27.9.4, 28.5. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/illustrator/apsb24-30.html
- https://helpx.adobe.com/security/products/illustrator/apsb24-30.html
Get alerted when CVE-2024-20792 or the next vulnerability affects your stack