What’s Vulnerable › Vulnerabilities
CVE-2024-2093: VK All in One Expansion Unit <= 9.95.0.1 - Information Exposure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-200
Description
The VK All in One Expansion Unit plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 9.95.0.1 via social meta tags. This makes it possible for unauthenticated attackers to view limited password protected content.
Affected products
- kurudrive VK All in One Expansion Unit: before 9.96.0.0 — fixed in 9.96.0.0
How to fix
Upgrade to a fixed version: kurudrive VK All in One Expansion Unit 9.96.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/vektor-inc/vk-all-in-one-expansion-unit/pull/1072
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3050823%40vk-all-in-one-expansion-unit&new=3050823%40vk-all-in-one-expansion-unit&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ea2b5dca-42a5-49d4-800d-b268572968a9?source=cve
- https://github.com/vektor-inc/vk-all-in-one-expansion-unit/pull/1072
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3050823%40vk-all-in-one-expansion-unit&new=3050823%40vk-all-in-one-expansion-unit&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ea2b5dca-42a5-49d4-800d-b268572968a9?source=cve
Get alerted when CVE-2024-2093 or the next vulnerability affects your stack