What’s Vulnerable › Vulnerabilities
CVE-2024-2098: Download Manager <= 3.2.89 - Improper Authorization via protectMediaLibrary
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-13 · updated 2026-06-17
- Weakness: CWE-289
Description
The Download Manager plugin for WordPress is vulnerable to unauthorized access of data due to an improper authorization check on the 'protectMediaLibrary' function in all versions up to, and including, 3.2.89. This makes it possible for unauthenticated attackers to download password-protected files.
Affected products
- codename065 Download Manager: before 3.2.90 — fixed in 3.2.90
How to fix
Upgrade to a fixed version: codename065 Download Manager 3.2.90. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3072712/download-manager
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1301c8af-d81a-40f1-96fa-e8252309d8a4?source=cve
- https://plugins.trac.wordpress.org/changeset/3072712/download-manager
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1301c8af-d81a-40f1-96fa-e8252309d8a4?source=cve
Get alerted when CVE-2024-2098 or the next vulnerability affects your stack