What’s Vulnerable › Vulnerabilities
CVE-2024-2101: WordPress Plugin Salon Booking System < 9.6.3 - Unauthenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 5.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The Salon booking system WordPress plugin before 9.6.3 does not properly sanitize and escape the 'Mobile Phone' field when booking an appointment, allowing customers to conduct Stored Cross-Site Scripting attacks. The payload gets triggered when an admin visits the 'Customers' page and the malicious script is executed in the admin context.
Affected products
- Salon booking system: before 9.6.3 — fixed in 9.6.3
How to fix
Upgrade to a fixed version: Salon booking system 9.6.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b3a0bb3f-50b2-4dcb-b23c-b08480363a4a/
- https://wpscan.com/vulnerability/b3a0bb3f-50b2-4dcb-b23c-b08480363a4a/
Get alerted when CVE-2024-2101 or the next vulnerability affects your stack