What’s Vulnerable › Vulnerabilities
CVE-2024-2118: Social Media Share Buttons < 2.8.9 - Admin+ Stored XSS via settings
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The Social Media Share Buttons & Social Sharing Icons WordPress plugin before 2.8.9 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Social Media Share Buttons & Social Sharing Icons: before 2.8.9 — fixed in 2.8.9
How to fix
Upgrade to a fixed version: Social Media Share Buttons & Social Sharing Icons 2.8.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e9d53cb9-a5cb-49f5-bcba-295ae6fa44c3/
- https://wpscan.com/vulnerability/e9d53cb9-a5cb-49f5-bcba-295ae6fa44c3/
Get alerted when CVE-2024-2118 or the next vulnerability affects your stack