What’s Vulnerable › Vulnerabilities
CVE-2024-2129: WPBITS Addons For Elementor Page Builder <= 1.4 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The WPBITS Addons For Elementor Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's heading widget in all versions up to, and including, 1.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- WPBITS Addons For Elementor Page Builder: before 1.4 — fixed in 1.4
How to fix
Upgrade to a fixed version: WPBITS Addons For Elementor Page Builder 1.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3098221%40wpbits-addons-for-elementor&new=3098221%40wpbits-addons-for-elementor&sfp_email=&sfph_mail=#file13
- https://wordpress.org/plugins/wpbits-addons-for-elementor/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/05cd8f96-533a-4036-a01f-6ba1ad2d2b5e?source=cve
- https://wordpress.org/plugins/wpbits-addons-for-elementor/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/05cd8f96-533a-4036-a01f-6ba1ad2d2b5e?source=cve
Get alerted when CVE-2024-2129 or the next vulnerability affects your stack