What’s Vulnerable › Vulnerabilities
CVE-2024-21312: .NET Framework Denial of Service Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-09 · updated 2026-06-17
- Weakness: CWE-20
Description
.NET Framework Denial of Service Vulnerability
Affected products
- Microsoft .NET Framework: 3.5, 4.8.1, 4.6.2, 4.7, 4.7.1, 4.7.2 (+1)
- Microsoft .NET Framework 3.5: from 3.5.0 before 3.0.50727.8976 — fixed in 3.0.50727.8976
- Microsoft .NET Framework 3.5 AND 4.7.2: from 4.7.0 before 4.7.04081.03 — fixed in 4.7.04081.03
- Microsoft .NET Framework 3.5 AND 4.8: from 4.8.0 before 4.8.04690.02 — fixed in 4.8.04690.02
- Microsoft .NET Framework 3.5 AND 4.8.1: from 4.8.1 before 4.8.09214.01 — fixed in 4.8.09214.01
- Microsoft .NET Framework 4.6.2/4.7/4.7.1/4.7.2: from 4.7.0 before 4.7.04081.02 — fixed in 4.7.04081.02
- Microsoft .NET Framework 4.8: from 4.8.0 before 4.8.04690.02 — fixed in 4.8.04690.02
How to fix
Upgrade to a fixed version: Microsoft .NET Framework 3.5 3.0.50727.8976; Microsoft .NET Framework 3.5 AND 4.7.2 4.7.04081.03; Microsoft .NET Framework 3.5 AND 4.8 4.8.04690.02; Microsoft .NET Framework 3.5 AND 4.8.1 4.8.09214.01; Microsoft .NET Framework 4.6.2/4.7/4.7.1/4.7.2 4.7.04081.02; Microsoft .NET Framework 4.8 4.8.04690.02. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2024-21312
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2024-21312
- https://security.netapp.com/advisory/ntap-20240208-0008/
Get alerted when CVE-2024-21312 or the next vulnerability affects your stack