What’s Vulnerable › Vulnerabilities
CVE-2024-2138: JetWidgets For Elementor <= 1.0.15 - Authenticated (Contributor+) Stored Cross-Site Scripting via Animated Box Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The JetWidgets For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Animated Box widget in all versions up to, and including, 1.0.15 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- jetmonsters JetWidgets For Elementor: before 1.0.16 — fixed in 1.0.16
How to fix
Upgrade to a fixed version: jetmonsters JetWidgets For Elementor 1.0.16. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3050010/jetwidgets-for-elementor
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f807b605-68a8-4340-a275-776eac0936fa?source=cve
- https://plugins.trac.wordpress.org/changeset/3050010/jetwidgets-for-elementor
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f807b605-68a8-4340-a275-776eac0936fa?source=cve
Get alerted when CVE-2024-2138 or the next vulnerability affects your stack