What’s Vulnerable › Vulnerabilities
CVE-2024-21409: .NET, .NET Framework, and Visual Studio Remote Code Execution Vulnerability
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-416
Description
.NET, .NET Framework, and Visual Studio Remote Code Execution Vulnerability
Affected products
- Microsoft .NET: from 6.0.0 before 6.0.29; from 7.0.0 before 7.0.18; from 8.0.0 before 8.0.4 — fixed in 6.0.29, 7.0.18, 8.0.4
- Microsoft .NET Framework: 3.5, 4.8.1, 4.7.2, 4.8, 4.6.2, 4.7 (+1)
- Microsoft Powershell: from 7.2 before 7.2.19; from 7.3 before 7.3.12; from 7.4 before 7.4.2 — fixed in 7.2.19, 7.3.12, 7.4.2
- Microsoft Visual Studio 2022 version 17.14: from 17.4.0 before 17.4.18; from 17.6.0 before 17.6.14; from 17.8.0 before 17.8.9; from 17.9.0 before 17.9.6 — fixed in 17.4.18, 17.6.14, 17.8.9, 17.9.6
- Microsoft .NET 6.0: from 6.0.0 before 6.0.29 — fixed in 6.0.29
- Microsoft .NET 7.0: from 7.0.0 before 7.0.18 — fixed in 7.0.18
- Microsoft .NET 8.0: from 8.0 before 8.0.4 — fixed in 8.0.4
- Microsoft .NET Framework 3.5 AND 4.7.2: from 4.7.0 before 4.7.4092.0 — fixed in 4.7.4092.0
- Microsoft .NET Framework 3.5 AND 4.8: from 4.8.0 before 4.8.4718.0 — fixed in 4.8.4718.0
- Microsoft .NET Framework 3.5 AND 4.8.1: from 4.8.1 before 4.8.9236.0 — fixed in 4.8.9236.0
- Microsoft .NET Framework 4.6.2: from 4.7.0 before 4.7.4092.0 — fixed in 4.7.4092.0
- Microsoft .NET Framework 4.6.2/4.7/4.7.1/4.7.2: from 4.7.0 before 4.7.4092.0 — fixed in 4.7.4092.0
- Microsoft .NET Framework 4.8: from 4.8.0 before 4.8.4718.0 — fixed in 4.8.4718.0
- Microsoft Visual Studio 2022 version 17.4: from 17.4.0 before 17.4.18 — fixed in 17.4.18
- Microsoft Visual Studio 2022 version 17.6: from 17.6.0 before 17.6.14 — fixed in 17.6.14
- Microsoft Visual Studio 2022 version 17.8: from 17.8.0 before 17.8.9 — fixed in 17.8.9
- Microsoft Visual Studio 2022 version 17.9: from 17.0 before 17.9.6 — fixed in 17.9.6
- Microsoft PowerShell 7.2: from 7.2.0 before 7.2.19 — fixed in 7.2.19
- Microsoft PowerShell 7.3: from 7.3.0 before 7.3.12 — fixed in 7.3.12
- Microsoft PowerShell 7.4: from 7.4.0 before 7.4.2 — fixed in 7.4.2
How to fix
Upgrade to a fixed version: Microsoft .NET 6.0.29, 7.0.18, 8.0.4; Microsoft Powershell 7.2.19, 7.3.12, 7.4.2; Microsoft Visual Studio 2022 version 17.14 17.4.18, 17.6.14, 17.8.9, 17.9.6; Microsoft .NET 6.0 6.0.29; Microsoft .NET 7.0 7.0.18; Microsoft .NET 8.0 8.0.4; Microsoft .NET Framework 3.5 AND 4.7.2 4.7.4092.0; Microsoft .NET Framework 3.5 AND 4.8 4.8.4718.0; Microsoft .NET Framework 3.5 AND 4.8.1 4.8.9236.0; Microsoft .NET Framework 4.6.2 4.7.4092.0; Microsoft .NET Framework 4.6.2/4.7/4.7.1/4.7.2 4.7.4092.0; Microsoft .NET Framework 4.8 4.8.4718.0. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2024-21409
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2024-21409
- https://security.netapp.com/advisory/ntap-20250117-0002/
Get alerted when CVE-2024-21409 or the next vulnerability affects your stack