What’s Vulnerable › Vulnerabilities
CVE-2024-21507
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-10 · updated 2026-06-17
- Weakness: CWE-20
Description
Versions of the package mysql2 before 3.9.3 are vulnerable to Improper Input Validation through the keyFromFields function, resulting in cache poisoning. An attacker can inject a colon (:) character within a value of the attacker-crafted key.
Affected products
- mysql2: before 3.9.3 — fixed in 3.9.3
How to fix
Upgrade to a fixed version: mysql2 3.9.3. Check the vendor advisory for mitigations.
References
- https://blog.slonser.info/posts/mysql2-attacker-configuration/
- https://github.com/sidorares/node-mysql2/commit/0d54b0ca6498c823098426038162ef10df02c818
- https://github.com/sidorares/node-mysql2/pull/2424
- https://security.snyk.io/vuln/SNYK-JS-MYSQL2-6591300
- https://blog.slonser.info/posts/mysql2-attacker-configuration/
- https://github.com/sidorares/node-mysql2/commit/0d54b0ca6498c823098426038162ef10df02c818
- https://github.com/sidorares/node-mysql2/pull/2424
- https://security.snyk.io/vuln/SNYK-JS-MYSQL2-6591300
Get alerted when CVE-2024-21507 or the next vulnerability affects your stack