What’s Vulnerable › Vulnerabilities
CVE-2024-21520
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-26 · updated 2026-06-17
- Weakness: CWE-79
Description
Versions of the package djangorestframework before 3.15.2 are vulnerable to Cross-site Scripting (XSS) via the break_long_headers template filter due to improper input sanitization before splitting and joining with <br> tags.
Affected products
- Django-Rest-Framework Django Rest Framework: before 3.15.2 — fixed in 3.15.2
How to fix
Upgrade to a fixed version: Django-Rest-Framework Django Rest Framework 3.15.2. Check the vendor advisory for mitigations.
References
- https://github.com/encode/django-rest-framework/commit/3b41f0124194430da957b119712978fa2266b642
- https://github.com/encode/django-rest-framework/pull/9435
- https://security.snyk.io/vuln/SNYK-PYTHON-DJANGORESTFRAMEWORK-7252137
- https://github.com/encode/django-rest-framework/commit/3b41f0124194430da957b119712978fa2266b642
- https://github.com/encode/django-rest-framework/compare/3.15.1...3.15.2
- https://github.com/encode/django-rest-framework/pull/9435
- https://security.snyk.io/vuln/SNYK-PYTHON-DJANGORESTFRAMEWORK-7252137
Get alerted when CVE-2024-21520 or the next vulnerability affects your stack