What’s Vulnerable › Vulnerabilities
CVE-2024-21529
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-11 · updated 2026-07-14
- Weakness: CWE-1321
Description
Versions of the package dset before 3.1.4 are vulnerable to Prototype Pollution via the dset function due improper user input sanitization. This vulnerability allows the attacker to inject malicious object property using the built-in Object property __proto__, which is recursively assigned to all the objects in the program.
Affected products
- dset: before 3.1.4 — fixed in 3.1.4
How to fix
Upgrade to a fixed version: dset 3.1.4. Check the vendor advisory for mitigations.
References
- https://github.com/lukeed/dset/commit/16d6154e085bef01e99f01330e5a421a7f098afa
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-7981555
- https://security.snyk.io/vuln/SNYK-JS-DSET-7116691
Get alerted when CVE-2024-21529 or the next vulnerability affects your stack