What’s Vulnerable › Vulnerabilities
CVE-2024-21530
- Severity: medium (CVSS 4.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-02 · updated 2026-06-17
- Weakness: CWE-323
Description
Versions of the package cocoon before 0.4.0 are vulnerable to Reusing a Nonce, Key Pair in Encryption when the encrypt, wrap, and dump functions are sequentially called. An attacker can generate the same ciphertext by creating a new encrypted message with the same cocoon object. **Note:** The issue does NOT affect objects created with Cocoon::new which utilizes ThreadRng.
Affected products
- Cocoon: before 0.4.0 — fixed in 0.4.0
How to fix
Upgrade to a fixed version: Cocoon 0.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-6878-6wc2-pf5h
- https://github.com/fadeevab/cocoon/commit/1b6392173ce35db4736a94b62b2d2973f9a71441
- https://github.com/fadeevab/cocoon/issues/22
- https://rustsec.org/advisories/RUSTSEC-2023-0068.html
- https://security.snyk.io/vuln/SNYK-RUST-COCOON-6028364
Get alerted when CVE-2024-21530 or the next vulnerability affects your stack