What’s Vulnerable › Vulnerabilities
CVE-2024-21534
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-11 · updated 2026-06-17
- Weakness: CWE-94
Description
All versions of the package jsonpath-plus are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of vm in Node. **Note:** There were several attempts to fix it in versions [10.0.0-10.1.0](https://github.com/JSONPath-Plus/JSONPath/compare/v9.0.0...v10.1.0) but it could still be exploited using [different payloads](https://github.com/JSONPath-Plus/JSONPath/issues/226).
Affected products
- Jsonpath-Plus Jsonpath: before 10.0.7 — fixed in 10.0.7
How to fix
Upgrade to a fixed version: Jsonpath-Plus Jsonpath 10.0.7. Check the vendor advisory for mitigations.
References
- https://github.com/JSONPath-Plus/JSONPath/compare/v9.0.0...v10.1.0
- https://github.com/JSONPath-Plus/JSONPath/issues/226
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-8185019
- https://security.snyk.io/vuln/SNYK-JS-JSONPATHPLUS-7945884
Get alerted when CVE-2024-21534 or the next vulnerability affects your stack