What’s Vulnerable › Vulnerabilities
CVE-2024-21535
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Versions of the package markdown-to-jsx before 7.4.0 are vulnerable to Cross-site Scripting (XSS) via the src property due to improper input sanitization. An attacker can execute arbitrary code by injecting a malicious iframe element in the markdown.
Affected products
- markdown-to-jsx: before 7.4.0 — fixed in 7.4.0
How to fix
Upgrade to a fixed version: markdown-to-jsx 7.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/quantizor/markdown-to-jsx/commit/8eb74da825c0d8d2e9508d73c672bcae36ba555a
- https://security.snyk.io/vuln/SNYK-JS-MARKDOWNTOJSX-6258886
Get alerted when CVE-2024-21535 or the next vulnerability affects your stack