What’s Vulnerable › Vulnerabilities
CVE-2024-21536: Denial of service in http-proxy-middleware
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-19 · updated 2026-08-01
- Weakness: CWE-400
Description
Versions of the package http-proxy-middleware before 2.0.7, from 3.0.0 and before 3.0.3 are vulnerable to Denial of Service (DoS) due to an UnhandledPromiseRejection error thrown by micromatch. An attacker could kill the Node.js process and crash the server by making requests to certain paths.
Affected products
- chimurai http-proxy-middleware: before 2.0.7; from 3.0.0 before 3.0.3 — fixed in 2.0.7, 3.0.3
- Npm Http-Proxy-Middleware: before 2.0.7; from 3.0.0 before 3.0.3 — fixed in 2.0.7, 3.0.3
How to fix
Upgrade to a fixed version: chimurai http-proxy-middleware 2.0.7, 3.0.3; Npm Http-Proxy-Middleware 2.0.7, 3.0.3. Check the vendor advisory for mitigations.
References
- https://gist.github.com/mhassan1/28be67266d82a53708ed59ce5dc3c94a
- https://github.com/chimurai/http-proxy-middleware/commit/0b4274e8cc9e9a2c5a06f35fbf456ccfcebc55a5
- https://github.com/chimurai/http-proxy-middleware/commit/788b21e4aff38332d6319557d4a5b1b13b1f9a22
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-8309098
- https://security.snyk.io/vuln/SNYK-JS-HTTPPROXYMIDDLEWARE-8229906
Get alerted when CVE-2024-21536 or the next vulnerability affects your stack