What’s Vulnerable › Vulnerabilities

CVE-2024-21538: Regular Expression Denial of Service (ReDoS) in cross-spawn

Description

Versions of the package cross-spawn before 6.0.6, from 7.0.0 and before 7.0.5 are vulnerable to Regular Expression Denial of Service (ReDoS) due to improper input sanitization. An attacker can increase the CPU usage and crash the program by crafting a very large and well crafted string.

Affected products

How to fix

Upgrade to a fixed version: Cross-Spawn 7.0.5; Npm Cross-Spawn 7.0.5, 6.0.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-21538 or the next vulnerability affects your stack