What’s Vulnerable › Vulnerabilities
CVE-2024-21539
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-19 · updated 2026-08-03
- Weakness: CWE-1333
Description
Versions of the package @eslint/plugin-kit before 0.2.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to improper input sanitization. An attacker can increase the CPU usage and crash the program by exploiting this vulnerability.
Affected products
- Eslint Rewrite: before 0.2.3 — fixed in 0.2.3
How to fix
Upgrade to a fixed version: Eslint Rewrite 0.2.3. Check the vendor advisory for mitigations.
References
- https://github.com/eslint/rewrite/commit/071be842f0bd58de4863cdf2ab86d60f49912abf
- https://security.snyk.io/vuln/SNYK-JS-ESLINTPLUGINKIT-8340627
Get alerted when CVE-2024-21539 or the next vulnerability affects your stack