What’s Vulnerable › Vulnerabilities
CVE-2024-21543
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-13 · updated 2026-06-17
- Weakness: CWE-287
Description
Versions of the package djoser before 2.3.0 are vulnerable to Authentication Bypass when the authenticate() function fails. This is because the system falls back to querying the database directly, granting access to users with valid credentials, and eventually bypassing custom authentication checks such as two-factor authentication, LDAP validations, or requirements from configured AUTHENTICATION_BACKENDS.
Affected products
- djoser: before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: djoser 2.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/sunscrapers/djoser/commit/d33c3993c0c735f23cbedc60fa59fce69354f19d
- https://github.com/sunscrapers/djoser/issues/795
- https://github.com/sunscrapers/djoser/pull/819
- https://github.com/sunscrapers/djoser/releases/tag/2.3.0
- https://security.snyk.io/vuln/SNYK-PYTHON-DJOSER-8366540
- https://lists.debian.org/debian-lts-announce/2025/02/msg00023.html
Get alerted when CVE-2024-21543 or the next vulnerability affects your stack