What’s Vulnerable › Vulnerabilities
CVE-2024-21548
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-18 · updated 2026-06-17
- Weakness: CWE-1321
Description
Versions of the package bun after 0.0.12 and before 1.1.30 are vulnerable to Prototype Pollution due to improper input sanitization. An attacker can exploit this vulnerability through Bun's APIs that accept objects. **Note:** This issue relates to the widely known and actively developed 'Bun' JavaScript runtime. The bun package on NPM at versions 0.0.12 and below belongs to a different and older project that happened to claim the 'bun' name in the past.
Affected products
- bun: from 0.0.12 before 1.1.30 — fixed in 1.1.30
How to fix
Upgrade to a fixed version: bun 1.1.30. Check the vendor advisory for mitigations.
References
- https://github.com/oven-sh/bun/commit/a234e067a5dc7837602df3fb5489e826920cc65a
- https://github.com/oven-sh/bun/pull/14119
- https://security.snyk.io/vuln/SNYK-JS-BUN-8499549
Get alerted when CVE-2024-21548 or the next vulnerability affects your stack