What’s Vulnerable › Vulnerabilities
CVE-2024-21549
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-20 · updated 2026-08-06
- Weakness: CWE-20
Description
Versions of the package spatie/browsershot before 5.0.3 are vulnerable to Improper Input Validation due to improper URL validation in the setUrl method. An attacker can exploit this vulnerability by utilizing view-source:file://, which allows for arbitrary file reading on a local file. **Note:** This is a bypass of the fix for [CVE-2024-21544](https://security.snyk.io/vuln/SNYK-PHP-SPATIEBROWSERSHOT-8496745).
Affected products
- spatie/browsershot: before 5.0.3 — fixed in 5.0.3
How to fix
Upgrade to a fixed version: spatie/browsershot 5.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/spatie/browsershot/commit/f791ce0ae8dd99367dbfa30588ee31e1196e1728
- https://github.com/spatie/browsershot/discussions/906
- https://security.snyk.io/vuln/SNYK-PHP-SPATIEBROWSERSHOT-8533023
Get alerted when CVE-2024-21549 or the next vulnerability affects your stack