What’s Vulnerable › Vulnerabilities
CVE-2024-21574
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-94
Description
The issue stems from a missing validation of the pip field in a POST request sent to the /customnode/install endpoint used to install custom nodes which is added to the server by the extension. This allows an attacker to craft a request that triggers a pip install on a user controlled package or URL, resulting in remote code execution (RCE) on the server.
Affected products
- ltdrdata ComfyUI-Manager: before 2.51.1 — fixed in 2.51.1
How to fix
Upgrade to a fixed version: ltdrdata ComfyUI-Manager 2.51.1. Check the vendor advisory for mitigations.
References
- https://github.com/ltdrdata/ComfyUI-Manager/blob/ffc095a3e5acc1c404773a0510e6d055a6a72b0e/glob/manager_server.py#L798
- https://github.com/ltdrdata/ComfyUI-Manager/commit/ffc095a3e5acc1c404773a0510e6d055a6a72b0e
Get alerted when CVE-2024-21574 or the next vulnerability affects your stack