What’s Vulnerable › Vulnerabilities
CVE-2024-2159: Sassy Social Share < 3.3.61 - Contributor+ Stored XSS
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The Social Sharing Plugin WordPress plugin before 3.3.61 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- heateor Social Sharing Plugin – Sassy Social Share: before 3.3.61 — fixed in 3.3.61
How to fix
Upgrade to a fixed version: heateor Social Sharing Plugin – Sassy Social Share 3.3.61. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d7fa9849-c82a-4efd-84b6-9245053975ba/
- https://wpscan.com/vulnerability/d7fa9849-c82a-4efd-84b6-9245053975ba/
Get alerted when CVE-2024-2159 or the next vulnerability affects your stack