What’s Vulnerable › Vulnerabilities
CVE-2024-21615: Junos OS and Junos OS Evolved: A low-privileged user can access confidential information
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-12 · updated 2026-06-17
- Weakness: CWE-276
Description
An Incorrect Default Permissions vulnerability in Juniper Networks Junos OS and Junos OS Evolved allows a local, low-privileged attacker to access confidential information on the system. On all Junos OS and Junos OS Evolved platforms, when NETCONF traceoptions are configured, and a super-user performs specific actions via NETCONF, then a low-privileged user can access sensitive information compromising the confidentiality of the system. This issue affects: Junos OS: * all versions before 21.2R3-S7, * from 21.4 before 21.4R3-S5, * from 22.1 before 22.1R3-S5, * from 22.2 before 22.2R3-S3, * from 22.3 before 22.3R3-S2, * from 22.4 before 22.4R3, * from 23.2 before 23.2R1-S2. Junos OS Evolved: * all versions before 21.2R3-S7-EVO, * from 21.3 before 21.3R3-S5-EVO, * from 21.4 before 21.4R3-S5-EVO, * from 22.1 before 22.1R3-S5-EVO, * from 22.2 before 22.2R3-S3-EVO, * from 22.3 before 22.3R3-S2-EVO, * from 22.4 before 22.4R3-EVO, * from 23.2 before 23.2R1-S2.
Affected products
- Juniper Junos OS: before 21.2; 21.2, 21.2-r1, 21.2-r1-s1, 21.2-r1-s2, 21.2-r2, 21.2-r2-s1 (+61) — fixed in 21.2
- Juniper Networks Junos OS Evolved: before 21.2; 21.2, 21.2-r1, 21.2-r1-s1, 21.2-r1-s2, 21.2-r2, 21.2-r2-s1 (+71) — fixed in 21.2
How to fix
Upgrade to a fixed version: Juniper Junos OS 21.2; Juniper Networks Junos OS Evolved 21.2. Check the vendor advisory for mitigations.
References
- https://supportportal.juniper.net/JSA75756
- https://www.first.org/cvss/calculator/4.0#CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:H/VI:N/VA:N/SC:L/SI:N/SA:N
- https://supportportal.juniper.net/JSA75756
- https://www.first.org/cvss/calculator/4.0#CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:H/VI:N/VA:N/SC:L/SI:N/SA:N
Get alerted when CVE-2024-21615 or the next vulnerability affects your stack